Returns the number of RhinoScript user data items on an object's attributes.
Rhino.AttributeDataCount (strObject)
strObject |
Required. String. The object's identifier. |
Number |
The number of RhinoScript object user data items if successful. |
Null |
If not successful, or on error. |
Dim strObject, intCount
strObject = Rhino.GetObject("Select object")
If Not IsNull(strObject) Then
intCount = Rhino.AttributeDataCount(strObject)
Rhino.Print "Object attribute user data count: " & CStr(intCount)
End If