IsAttributeData

Obsolete - use IsUserText

Verifies that an object's attributes contains RhinoScript user data.

Syntax

Rhino.IsAttributeData (strObject)

Parameters

strObject

Required.  String.  The object's identifier.

Returns

Boolean

True or False indicating whether or not the object's attributes contains any RhinoScript user data if successful.

Null

If not successful, or on error.

Example

Dim strObject, blnResult

strObject = Rhino.GetObject("Select object")

If Not IsNull(strObject) Then

blnResult = Rhino.IsAttributeData (strObject)

If blnResult = True Then

Rhino.Print "This object's attributes contains RhinoScript user data"

Else

Rhino.Print "This object's attributes contains no RhinoScript user data"

End If

End If

Also See

AttributeDataCount

DeleteAttributeData

GetAttributeData

SetAttributeData