GetMeshVertices

Prompts the user to pick, or select, one or more mesh vertices.

Syntax

Rhino.GetMeshVertices (strObject [, strMessage [, intMinCount [, intMaxCount]]])

Parameters

strObject

Required.  String.  The mesh object's identifier.

strMessage

Optional.  String.  A prompt or message.

intMinCount

Optional.  Number.  The minimum number of vertices to select.  The default number is 1.

intMaxCount

Optional.  Number.  The maximum number of vertices to select.  If intMaxCount is 0, then the user must press enter to finish selection.  If intMaxCount is -1, then selection stops as soon as there are at least intMinCount vertices selected.  If intMinCount > 0, then the picking stops when there are intMaxCount vertices.  The default number is 0.

Returns

Array

An array of mesh vertex indices if successful.

Null

If not successful, or on error.

Example

Dim strMesh, arrIndices

strMesh = Rhino.GetObject("Select mesh", 32)

If Not IsNull(strMesh) Then

  arrIndices = Rhino.GetMeshVertices(strMesh)

  If IsArray(arrIndices) Then

    For i = 0 To UBound(arrIndices)

      Rhino.Print arrIndices(i)

    Next

  End If

End If

Also See

GetMeshFaces

MeshFaces

MeshFaceVertices

MeshVertices