Returns or changes the current Windows printer.
Rhino.CurrentPrinter ([strPrinter])
strPrinter |
Optional. String. The name of a Windows printer as returned by this method or by the PrinterNames method. |
String |
If strPrinter is not specified, the name of the current Windows printer if successful. |
String |
If strPrinter is specified, the name of the previously current Windows printer if successful. |
Null |
If not successful, or on error. |
Dim arrPrinters, strPrinter
arrPrinters = Rhino.PrinterNames
If IsArray(arrPrinters) Then
strPrinter = Rhino.CurrentPrinter
strPrinter = Rhino.ListBox(arrPrinters, "Current: " & strPrinter, "Set Current Printer")
If Not IsNull(strPrinter) Then
Rhino.CurrentPrinter strPrinter
End If
End If