Utility Methods

RhinoScript contains several utility methods to assist in creating scripts.

 

Method

Description

AllProcedures

Returns the user-defined procedures in RhinoScript.

ClipboardText

Returns text from or sets text to the Windows Clipboard.

ColorAdjustLuma

Changes the luminance of an RGB value.

ColorBlueValue

Retrieves an intensity value for the blue component of a red-green-blue (RGB) value.

ColorGreenValue

Retrieves an intensity value for the green component of a red-green-blue (RGB) value.

ColorHLSToRGB

Converts colors from hue-luminance-saturation (HLS) to RGB format.

ColorHSVToRGB

Converts colors from hue-saturation-value (HSV) to RGB format.

ColorRedValue

Retrieves an intensity value for the red component of a red-green-blue (RGB) value.

ColorRGBToHLS

Converts colors from RGB to hue-luminance-saturation (HLS) format.

ColorRGBToHSV

Converts colors from RGB to hue-saturation-value (HSV) format.

CullDuplicateNumbers

Remove duplicates from an array of numbers.

CullDuplicatePoints

Remove duplicates from an array of 3-D points.

CullDuplicateStrings

Remove duplicates from an array of strings.

CurrentPrinter

Returns or sets the current Windows printer.

FindDuplicateNumbers

Finds duplicate numbers in a VBScript Array.

FindDuplicatePoints

Finds duplicate points in a VBScript Array.

FindDuplicateStrings

Finds duplicate strings in a VBScript Array.

GetAsyncKeyState

Determines whether a key is up or down at the time the function is called.

GetSettings

Returns a string from a Windows INI-style file.

GetSystemMetrics

Retrieves the specified system metric or system configuration setting.

ImageInfo

Returns information about a bitmap image.

IntersectStrings

Returns the intersection of two string arrays.

IsProcedure

Verifies that a user-defined procedure is resident in RhinoScript.

JoinArrays

Joins two one-dimensional arrays into one.

MakeArray

Creates a new, initialized array of a user-specified bounds.

OnCancelScript

User-definable cancel script event handler.

PlaySound

Plays a sound specified by the given file name.

PrinterNames

Returns the name of all installed Windows printers.

Pt2Str

Converts a 3-D point value to a string.

ReadDelimitedFile

Reads a delimited text file.

ReadTextFile

Reads a text file.

SaveSettings

Saves a string value to a Windows INI-style file.

SimplyArray

Converts an array of 3-D points into a single-dimensional array.

Sleep

Suspends the execution of the script for the specified interval.

SortNumbers

Sorts an array of numbers.

SortPointList

Sort an array of points so they will be connected in "reasonable" polyline order.

SortPoints

Sorts an array of 3-D points.

SortPointsByDistance

Sorts an array of 3-D point based on the distance from a reference point.

SortStrings

Sorts an array of strings.

SpooltoPrinter

Spools a raw file to a Windows printer.

Str2Pt

Converts a formatted string to a 3-D point value.

Str2PtArray

Converts a formatted string to an array of 3-D point value.

Strtok

Returns the tokens in a string.

TextOut

Displays a text output window.

UnionStrings

Returns the union of two string arrays.

Version

Returns the version of RhinoScript.

WriteTextFile

Writes an array of strings to a text file.