GetSystemMetrics

Retrieves the specified system metric or system configuration setting   Note that all dimensions retrieved by GetSystemMetrics are in pixels.

For more information, see MSDN for information on the GetSystemMetrics Windows API function.

Syntax

Rhino.GetSystemMetrics (intINdex)

Parameters

intKey

Required.  Number.  The system metric or configuration setting to be retrieved.  For more information, see MSDN for information on the GetSystemMetrics Windows API function.

Returns

Boolean

If the function succeeds, the return value is the requested system metric or configuration setting.

Null

On error.

Example

Const SM_SWAPBUTTON = 23

Dim nSwapped

nSwapped = Rhino.GetSystemMetrics(SM_SWAPBUTTON)

If nSwapped <> 0 Then

  Rhino.Print "Left and right mouse buttons are swapped"

Else

  Rhino.Print "Left and right mouse buttons are not swapped"

End If

Also See

GetAsyncKeyState