Returns the plane geometry of the specified named construction plane.
Rhino.NamedCPlane (strName)
strName |
Required. String. The name of a named construction plane. |
Array |
An array containing the plane. The elements of a construction plane array are as follows:
|
||||||||||
Null |
If not successful, or on error. |
Dim arrCPlanes, arrPlane
arrCPlanes = Rhino.NamedCPlanes
If IsArray(arrCPlanes) Then
arrPlane = Rhino.NamedCPlane(arrCPlanes(0))
Rhino.Print "CPlane origin: " & Rhino.Pt2Str(arrPlane(0))
Rhino.Print "CPlane x-axis: " & Rhino.Pt2Str(arrPlane(1))
Rhino.Print "CPlane y-axis: " & Rhino.Pt2Str(arrPlane(2))
Rhino.Print "CPlane z-axis: " & Rhino.Pt2Str(arrPlane(3))
End If