RotateCamera

Rotates a perspective-projected view's camera. See the RotateCamera command in the Rhino help file for more details.

Syntax

Rhino.RotateCamera ([strview [, intDirection [, dblAngle]]])

Parameters

strView

Optional.  String.  The title or identifier of the view.  If omitted, the current active view is used.

intDirection

Optional. Number, The direction to rotate the camera where 0 = right, 1 = left, 2 = down, and 3 = up. The default is 0 = right.

dblAngle

Optional.  Number.  The angle to rotate. If omitted, the angle of rotation is specified by the "Increment in divisions of a circle" parameter specified in Options command's View tab.

Returns

Boolean

True or False indicating success or failure.

Null

On error.

Example

Dim strView

strView = Rhino.CurrentView

Rhino.RotateCamera strView, 0, 15

Also See

RotateView

TiltView