RotateView

Rotates a view. See the RotateView command in the Rhino help file for more information.

Syntax

Rhino.RotateView ([strview [, intDirection [, dblAngle]]])

Parameters

strView

Optional.  String.  The title or identifier of the view.  If omitted, the current active view is used.

intDirection

Optional. Number.  The direction to rotate the view, where 0 = Right, 1 = Left, 2 = Down, and 3 = Up. The default is Right (0).

dblAngle

Optional.  Number.  The angle to rotate. If omitted, the angle of rotation is specified by the "Increment in divisions of a circle" parameter specified in Options command's View tab.

Returns

Boolean

True or False indicating success or failure.

Null

On error.

Example

Dim strView

strView = Rhino.CurrentView

Rhino.RotateView strView, 0, 90.0

Also See

RotateCamera

TiltView