Returns the names, or titles, or identifiers of all views in the document.
Rhino.ViewNames ([blnReturnNames [, intType]])
blnReturnNames |
Optional. Boolean. If True (default), then the names, or titles, of the views are returned. If False, then the identifiers of the views are returned. |
||||||||
intType |
Optional. Number. The type of view to return, where:
|
Array |
A array of strings identifying the view names, or titles, or identifiers if successful. |
Null |
If not successful, or on error. |
Dim arrViews, strView
' Print view names
arrViews = Rhino.ViewNames
If IsArray(arrViews) Then
For Each strView in arrViews
Rhino.Print strView
Next
End If
' Print view identifiers
arrViews = Rhino.ViewNames(False)
For Each strView In arrViews
Rhino.Print strView & " = " & Rhino.ViewTitle(strView )
Next