Click or drag to resize

GH_ItemWrite Method (BinaryWriter)

Serialize this item into a binary stream.

Namespace:  GH_IO.Types
Assembly:  GH_IO (in GH_IO.dll)
Syntax
public void Write(
	BinaryWriter writer
)

Parameters

writer
Type: System.IOBinaryWriter
Writer to serialize with.

Implements

GH_IBinarySupportWrite(BinaryWriter)
Exceptions
ExceptionCondition
MemberAccessExceptionThrown if !HasName.
MemberAccessExceptionThrown if !HasType.
IOExceptionThrown if the internal data could not be serialized.
See Also