Click or drag to resize

GH_GDI_UtilFilletPolyline Method (Point, Int32)

Fillet all the corners of a freeform outline.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static GraphicsPath FilletPolyline(
	Point[] corners,
	int radius
)

Parameters

corners
Type: System.DrawingPoint
A list of corner points.
radius
Type: SystemInt32
Fillet to apply to all corners.

Return Value

Type: GraphicsPath
A graphics path describing the filleted shape, or Nothing on failure.
See Also