Click or drag to resize

GH_GDI_UtilFilletPolyline Method (PointF, Single)

Fillet all the corners of a freeform outline.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static GraphicsPath FilletPolyline(
	PointF[] corners,
	float radius
)

Parameters

corners
Type: System.DrawingPointF
A list of corner points.
radius
Type: SystemSingle
Fillet to apply to all corners.

Return Value

Type: GraphicsPath
A graphics path describing the filleted shape, or Nothing on failure.
See Also