Click or drag to resize

GH_GraphicsUtilAppendArc Method (Point3d, Point3d, Vector3d, GraphicsPath)

Append an arc segment to a GraphicsPath. If the arc cannot be solved, a linear segment is appended instead.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static void AppendArc(
	Point3d p0,
	Point3d p1,
	Vector3d dir,
	GraphicsPath path
)

Parameters

p0
Type: Point3d
Start point of arc.
p1
Type: Point3d
End point of arc.
dir
Type: Vector3d
Tangent direction at start of arc.
path
Type: System.Drawing.Drawing2DGraphicsPath
Path to append to.
See Also