Click or drag to resize

GH_GraphicsUtilAppendArc Method (PointF, PointF, SizeF, GraphicsPath)

Append an arc segment to a GraphicsPath. If the arc cannot be solved, a linear segment is appended instead.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static void AppendArc(
	PointF p0,
	PointF p1,
	SizeF dir,
	GraphicsPath path
)

Parameters

p0
Type: System.DrawingPointF
Start point of arc.
p1
Type: System.DrawingPointF
End point of arc.
dir
Type: System.DrawingSizeF
Tangent direction at start of arc.
path
Type: System.Drawing.Drawing2DGraphicsPath
Path to append to.
See Also