Click or drag to resize

GH_GraphicsUtilEtchHorizontal Method (Graphics, Int32, Int32, Int32, Int32, Int32)

Draws an etched line segment.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static void EtchHorizontal(
	Graphics g,
	int x0,
	int x1,
	int y,
	int alphaLight = 200,
	int alphaDark = 35
)

Parameters

g
Type: System.DrawingGraphics
Graphics object to draw with.
x0
Type: SystemInt32
x component of start point.
x1
Type: SystemInt32
x component of end point.
y
Type: SystemInt32
y component of line segment.
alphaLight (Optional)
Type: SystemInt32
Alpha level of etched lit line.
alphaDark (Optional)
Type: SystemInt32
Alpha level of etched shadow line.
See Also