Click or drag to resize

GH_GraphicsUtilRenderBalloonTag Method (Graphics, String, Font, Color, Color, PointF, Boolean)

Draw a balloon tag in a container.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static void RenderBalloonTag(
	Graphics g,
	string text,
	Font font,
	Color backColor,
	Color foreColor,
	PointF tip,
	bool upright
)

Parameters

g
Type: System.DrawingGraphics
Graphics object to draw with.
text
Type: SystemString
Text of tag.
font
Type: System.DrawingFont
Font of tag.
backColor
Type: System.DrawingColor
Background colour of balloon.
foreColor
Type: System.DrawingColor
Foreground colour of balloon edge and text.
tip
Type: System.DrawingPointF
Tip of balloon.
upright
Type: SystemBoolean
If true, the balloon will be above the tip point.
See Also