Click or drag to resize

GH_GraphicsUtilRenderHighlightBox Method (Graphics, Rectangle, Int32, Boolean, Boolean)

Render a typical blueish highlight rectangle

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static void RenderHighlightBox(
	Graphics g,
	Rectangle box,
	int cornerRadius,
	bool drawFill,
	bool drawEdge
)

Parameters

g
Type: System.DrawingGraphics
Graphics object to render with.
box
Type: System.DrawingRectangle
Dimensions of selection box.
cornerRadius
Type: SystemInt32
Radius (in pixels) of box corners, use zero or less to render crisp rectangles.
drawFill
Type: SystemBoolean
If true, the box fill have a blue background.
drawEdge
Type: SystemBoolean
If true, the box will have a blue edge.
See Also