Click or drag to resize

GH_GraphicsUtilShadowHorizontal Method (Graphics, Int32, Int32, Int32, Int32, Boolean, Int32)

Draws a horizontal shadow edge.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static void ShadowHorizontal(
	Graphics g,
	int x0,
	int x1,
	int y,
	int size = 10,
	bool below = true,
	int darkness = 50
)

Parameters

g
Type: System.DrawingGraphics
Graphics object to draw with.
x0
Type: SystemInt32
Start of shadow edge.
x1
Type: SystemInt32
End of shadow edge.
y
Type: SystemInt32
Elevation of shadow edge.
size (Optional)
Type: SystemInt32
Length of cast shadow.
below (Optional)
Type: SystemBoolean
If true, shadow is drawn below elevation line.
darkness (Optional)
Type: SystemInt32
Alpha component of darkness directly underneath the edge.
See Also