Click or drag to resize

GH_GraphicsUtilShadowHorizontal Method (Graphics, Single, Single, Single, Single, Boolean, Int32)

Draws a horizontal shadow edge.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static void ShadowHorizontal(
	Graphics g,
	float x0,
	float x1,
	float y,
	float size = 10f,
	bool below = true,
	int darkness = 50
)

Parameters

g
Type: System.DrawingGraphics
Graphics object to draw with.
x0
Type: SystemSingle
Start of shadow edge.
x1
Type: SystemSingle
End of shadow edge.
y
Type: SystemSingle
Elevation of shadow edge.
size (Optional)
Type: SystemSingle
Length of cast shadow.
below (Optional)
Type: SystemBoolean
If true, shadow is drawn below elevation line.
darkness (Optional)
Type: SystemInt32
Alpha component of darkness directly underneath the edge.
See Also