Click or drag to resize

GH_GraphicsUtilShadowRectangle Method (Graphics, Rectangle, Int32, Int32)

Draws shadow edges on the interior of a rectangle.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static void ShadowRectangle(
	Graphics g,
	Rectangle rec,
	int size = 10,
	int darkness = 50
)

Parameters

g
Type: System.DrawingGraphics
Graphics object to draw with.
rec
Type: System.DrawingRectangle
Bounding rectangle.
size (Optional)
Type: SystemInt32
Length of cast shadow.
darkness (Optional)
Type: SystemInt32
Alpha component of darkness directly underneath the edge.
See Also