Click or drag to resize

GH_GraphicsUtilSolveArc Method (Point3d, Point3d, Vector3d, RectangleF, Single, Single)

Create a GDI circular arc definition from start-point, end-point and tangent direction.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static bool SolveArc(
	Point3d p0,
	Point3d p1,
	Vector3d dir,
	ref RectangleF box,
	ref float angle,
	ref float sweep
)

Parameters

p0
Type: Point3d
Start point of arc.
p1
Type: Point3d
End point of arc.
dir
Type: Vector3d
Tangent direction at start of arc.
box
Type: System.DrawingRectangleF
Bounding box of arc (out)
angle
Type: SystemSingle
Start angle of arc (out)
sweep
Type: SystemSingle
Sweep angle of arc (out)

Return Value

Type: Boolean
True on success, false on failure.
See Also