Click or drag to resize

GH_GraphicsUtilSolveArc Method (Double, Double, Double, Double, Double, Double, RectangleF, Single, Single)

Create a GDI circular arc definition from start-point, end-point and tangent direction.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static bool SolveArc(
	double p0X,
	double p0Y,
	double p1X,
	double p1Y,
	double dx,
	double dy,
	ref RectangleF box,
	ref float angle,
	ref float sweep
)

Parameters

p0X
Type: SystemDouble
p0Y
Type: SystemDouble
p1X
Type: SystemDouble
p1Y
Type: SystemDouble
dx
Type: SystemDouble
dy
Type: SystemDouble
box
Type: System.DrawingRectangleF
angle
Type: SystemSingle
sweep
Type: SystemSingle

Return Value

Type: Boolean
See Also