Click or drag to resize

GH_StructureTShortestPathIndex Method

Finds the path in this structure with the least dimensions. In case of multiple equally long longest paths, the first one will be returned.

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public int ShortestPathIndex()

Return Value

Type: Int32
The index of the shortest path or -1 if there are no paths.

Implements

IGH_StructureShortestPathIndex
See Also