Click or drag to resize

GH_Chunk Methods

The GH_Chunk type exposes the following members.

Methods
  NameDescription
Public methodAddComment
Adds a text comment to this chunk. Comments are serialized only if the output flavour is a human readable format. Comments are never deserialized, they are purely for the benefit of the humans reading the file data.
Public methodAddMessage
Log a new message with the top-level archive. Messages are collected during read/write operations, and can be displayed to the user upon completion using GH_Archive.ShowMessageLog().
Public methodChunkExists(String)
Checks whether a chunk with the specified name exists in the litter. Only chunks without index qualifiers are considered. Name comparisons are not case-sensitive.
Public methodChunkExists(String, Int32)
Checks whether a chunk with the specified name and index exists in the litter. Only chunks with index qualifiers are considered. Name comparisons are not case-sensitive.
Public methodCopyValuesFromChunk
Copy all values and sub-chunks from another chunk.
Public methodCopyValuesToChunk
Copy all values and sub-chunks in this chunk to another chunk which does not point to the same archive.
Public methodCreateChunk(String)
Create a new child chunk with the specified name and without an index qualifier. If another chunk already exists with similar properties, an exception will be thrown.
Public methodCreateChunk(String, Int32)
Create a new child chunk with the specified name and index qualifier. If another chunk already exists with similar properties, an exception will be thrown.
Public methodFindChunk(String)
Finds the first chunk in the litter that matches the given name. Only chunks without index qualifiers are considered.
Public methodFindChunk(String, Int32)
Finds the first chunk in the list that matches the given name and index. Only chunks with index qualifiers are considered.
Public methodFindItem(String)
Finds the first item that matches the given name. Only items without index qualifiers are considered. Name comparisons are not case-sensitive.
Public methodFindItem(String, Int32)
Finds the first item that matches the given name and index. Only items with index qualifiers are considered. Name comparisons are not case-sensitive.
Public methodGetBoolean(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetBoolean(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetBoundingBox(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetBoundingBox(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetByte(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetByte(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetByteArray(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetByteArray(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetDate(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetDate(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetDecimal(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetDecimal(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetDouble(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetDouble(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetDoubleArray(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetDoubleArray(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetDrawingBitmap(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetDrawingBitmap(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetDrawingColor(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetDrawingColor(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetDrawingPoint(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetDrawingPoint(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetDrawingPointF(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetDrawingPointF(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetDrawingRectangle(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetDrawingRectangle(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetDrawingRectangleF(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetDrawingRectangleF(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetDrawingSize(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetDrawingSize(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetDrawingSizeF(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetDrawingSizeF(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetGuid(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetGuid(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetInt32(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetInt32(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetInt64(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetInt64(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetInterval1D(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetInterval1D(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetInterval2D(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetInterval2D(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetLine(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetLine(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetPath(String, String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetPath(String, Int32, String)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetPlane(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetPlane(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetPoint2D(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetPoint2D(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetPoint3D(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetPoint3D(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetPoint4D(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetPoint4D(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetSingle(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetSingle(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetString(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetString(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodGetVersion(String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodGetVersion(String, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodStatic memberInstantiateRoot
Construct a new instance of GH_Chunk which acts as a Root node. If you must create a chunk from scratch, use this static method to create one.
Public methodItemExists(String)
Gets the occupancy for a specific item name. Only items without index qualifiers are considered.
Public methodItemExists(String, Int32)
Checks whether an item with the specified name and index exists. Only items with index qualifiers are considered. Name comparisons are not case-sensitive.
Public methodRead(BinaryReader)
Read this chunk and all child chunks from a binary stream.
Public methodRead(XmlNode)
Read this chunk and all child chunks from an Xml node.
Public methodRemoveChunk(GH_IChunk)
Remove the specified chunk from the litter.
Public methodRemoveChunk(String)
Remove the first chunk with a matching name. Only chunks without index qualifiers are considered. Name comparisons are not case-sensitive.
Public methodRemoveChunk(String, Int32)
Remove the first chunk with a matching name and index. Only chunks with index qualifiers are considered. Name comparisons are not case-sensitive.
Public methodRemoveItem(String)
Remove an unindexed item from this chunk.
Public methodRemoveItem(String, Int32)
Remove an indexed item from this chunk.
Public methodSetBoolean(String, Boolean)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetBoolean(String, Int32, Boolean)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetBoundingBox(String, GH_BoundingBox)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetBoundingBox(String, Int32, GH_BoundingBox)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetByte(String, Byte)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetByte(String, Int32, Byte)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetByteArray(String, Byte)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetByteArray(String, Int32, Byte)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetDate(String, DateTime)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetDate(String, Int32, DateTime)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetDecimal(String, Decimal)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetDecimal(String, Int32, Decimal)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetDouble(String, Double)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetDouble(String, Int32, Double)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetDoubleArray(String, Double)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetDoubleArray(String, Int32, Double)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetDrawingBitmap(String, Bitmap)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetDrawingBitmap(String, Int32, Bitmap)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetDrawingColor(String, Color)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetDrawingColor(String, Int32, Color)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetDrawingPoint(String, Point)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetDrawingPoint(String, Int32, Point)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetDrawingPointF(String, PointF)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetDrawingPointF(String, Int32, PointF)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetDrawingRectangle(String, Rectangle)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetDrawingRectangle(String, Int32, Rectangle)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetDrawingRectangleF(String, RectangleF)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetDrawingRectangleF(String, Int32, RectangleF)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetDrawingSize(String, Size)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetDrawingSize(String, Int32, Size)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetDrawingSizeF(String, SizeF)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetDrawingSizeF(String, Int32, SizeF)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetGuid(String, Guid)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetGuid(String, Int32, Guid)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetInt32(String, Int32)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetInt32(String, Int32, Int32)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetInt64(String, Int64)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetInt64(String, Int32, Int64)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetInterval1D(String, GH_Interval1D)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetInterval1D(String, Int32, GH_Interval1D)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetInterval2D(String, GH_Interval2D)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetInterval2D(String, Int32, GH_Interval2D)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetLine(String, GH_Line)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetLine(String, Int32, GH_Line)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetPath(String, String, String)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetPath(String, Int32, String, String)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetPlane(String, GH_Plane)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetPlane(String, Int32, GH_Plane)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetPoint2D(String, GH_Point2D)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetPoint2D(String, Int32, GH_Point2D)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetPoint3D(String, GH_Point3D)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetPoint3D(String, Int32, GH_Point3D)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetPoint4D(String, GH_Point4D)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetPoint4D(String, Int32, GH_Point4D)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetSingle(String, Single)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetSingle(String, Int32, Single)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetString(String, String)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetString(String, Int32, String)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetVersion(String, GH_Version)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetVersion(String, Int32, GH_Version)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetVersion(String, Int32, Int32, Int32)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetVersion(String, Int32, Int32, Int32, Int32)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodTryGetBoolean(String, Boolean)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetBoolean(String, Int32, Boolean)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetBoundingBox(String, GH_BoundingBox)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetBoundingBox(String, Int32, GH_BoundingBox)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetByte(String, Byte)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetByte(String, Int32, Byte)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetDate(String, DateTime)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetDate(String, Int32, DateTime)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetDecimal(String, Decimal)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetDecimal(String, Int32, Decimal)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetDouble(String, Double)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetDouble(String, Int32, Double)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetDrawingColor(String, Color)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetDrawingColor(String, Int32, Color)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetDrawingPoint(String, Point)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetDrawingPoint(String, Int32, Point)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetDrawingPointF(String, PointF)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetDrawingPointF(String, Int32, PointF)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetDrawingRectangle(String, Rectangle)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetDrawingRectangle(String, Int32, Rectangle)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetDrawingRectangleF(String, RectangleF)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetDrawingRectangleF(String, Int32, RectangleF)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetDrawingSize(String, Size)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetDrawingSize(String, Int32, Size)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetDrawingSizeF(String, SizeF)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetDrawingSizeF(String, Int32, SizeF)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetGuid(String, Guid)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetGuid(String, Int32, Guid)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetInt32(String, Int32)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetInt32(String, Int32, Int32)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetInt64(String, Int64)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetInt64(String, Int32, Int64)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetInterval1D(String, GH_Interval1D)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetInterval1D(String, Int32, GH_Interval1D)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetInterval2D(String, GH_Interval2D)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetInterval2D(String, Int32, GH_Interval2D)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetLine(String, GH_Line)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetLine(String, Int32, GH_Line)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetPlane(String, GH_Plane)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetPlane(String, Int32, GH_Plane)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetPoint2D(String, GH_Point2D)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetPoint2D(String, Int32, GH_Point2D)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetPoint3D(String, GH_Point3D)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetPoint3D(String, Int32, GH_Point3D)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetPoint4D(String, GH_Point4D)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetPoint4D(String, Int32, GH_Point4D)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetSingle(String, Single)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetSingle(String, Int32, Single)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetString(String, String)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetString(String, Int32, String)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodTryGetVersion(String, GH_Version)
Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public methodTryGetVersion(String, Int32, GH_Version)
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public methodWrite(BinaryWriter)
Write this chunk and all child chunks to a binary stream.
Public methodWrite(XmlWriter)
Serialize this chunk into an Xml stream.
Top
See Also