Click or drag to resize

GH_DigitNumber Properties

The GH_DigitNumber type exposes the following members.

Properties
  NameDescription
Public propertyDigitCount
Gets or sets the amount of digits in this number.
Public propertyEpsilon
Gets the smallest possible change.
Public propertyIsPrimaryDigitSignificant
Gets whether the primary digit at the given index is significant.
Public propertyIsSecondaryDigitSignificant
Gets whether the secondary digit at the given index is significant.
Public propertyMaximum
Gets the maximum value allowed in this number.
Public propertyMinimum
Gets the minimum value allowed in this number.
Public propertyOffset
Gets the offset between the primary and secondary digits.
Public propertyPrimaryDigits
Gets the internal list of primary digits. Do not modify this list.
Public propertyPrimaryPositive
Gets or sets a value indicating whether the number is positive.
Public propertyRadix
Gets or sets the radix point index. A negative radix index disables the radix point, zero is not a valid index.
Public propertyRadixIndex
Gets the mapped radix.
Public propertySecondaryDigits
Gets the internal list of secondary digits. Do not modify this list.
Public propertySecondaryPositive
Gets a value indicating whether the secondary number is positive.
Public propertyValue
Gets or sets the value of this number.
Top
See Also