Click or drag to resize

GH_AsynchFileData Properties

The GH_AsynchFileData type exposes the following members.

Properties
  NameDescription
Public propertyCallback
Gets or sets the callback delegate to be used when properties are updated.
Public propertyFileCreated
Gets the date at which the file was created.
Public propertyFileExists
Gets whether the file exists. Note that this property returns false if DataExists=False, regardless of whether the file exists.
Public propertyFileLastChanged
Gets the date at which the file was last changed.
Public propertyFileSize
Gets the size of the file.
Public propertyFileThumbnail
Gets the thumbnail bitmap associated with the file.
Public propertyHarvestThumbnail
Gets or sets whether the thumbnail ought to be parsed. At the moment this only makes sense for GH/GHX files.
Public propertyIsFileData
Gets whether the data has been retrieved at least once.
Top
See Also