Click or drag to resize

IGH_Attributes Properties

The IGH_Attributes type exposes the following members.

Properties
  NameDescription
Public propertyAllowMessageBalloon
Gets a value indicating whether these attributes allow warning and error boxes to be drawn on top of them.
Public propertyBounds
Gets the rectangle that contains the active content of the attributes. Typically the Contents determine the active area for menus, tooltips etc. Attributes are not supposed to draw objects beyond the Bounds.
Public propertyDocObject
Gets the owner object of these attributes.
Public propertyGetTopLevel
Gets the top level attributes of these attributes.
Public propertyHasInputGrip
Gets a value indicating whether or not these attributes have an input grip.
Public propertyHasOutputGrip
Gets a value indicating whether or not these attributes have an output grip.
Public propertyInputGrip
Gets the input grip location for these attributes. If HasInputGrip equals False, this point is meaningless.
Public propertyInstanceGuid
Gets the instance ID for these attributes.
Public propertyIsTopLevel
Gets whether these attributes are top_level (i.e. no Parent attributes)
Public propertyOutputGrip
Gets the output grip location for these attributes. If HasOutputGrip equals False, this point is meaningless.
Public propertyParent
Gets or sets the parent attributes. Top level attributes do not have parents.
Public propertyPathName
Get a description of the location of these attributes within the local attribute tree.
Public propertyPivot
Gets the pivot for these attributes. The pivot controls the general placement of the attributes. If you want to move the attributes, change the pivot location.
Public propertySelected
Gets or sets the selected state of the top-level attributes.
Top
See Also