Click or drag to resize

IGH_Param Properties

The IGH_Param type exposes the following members.

Properties
  NameDescription
Public propertyAccess
Gets or sets the Access level for this parameter.
Public propertyDataMapping
Gets or sets the data mapping of this Parameter.
Public propertyDataType
Gets the type of the current data state.
Public propertyHasProxySources
Gets a value indicating whether or not this parameter maintains proxy sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources.
Public propertyKind
Gets the parameter kind. The kind is evaluated lazily and cached.
Public propertyOptional
Gets or sets whether or not this parameter is considered optional by the owner component. Empty, non-optional parameters prevent the component from being solved.
Public propertyProxySourceCount
Gets the number of proxy sources for this parameter. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources.
Public propertyRecipients
Gets a list of all the recipients of this parameter. I.e. a recipient has this parameter as one of the sources. The Recipient list is maintained by the parameter, do not modify it yourself.
Public propertyReverse
Gets or sets the data reverse modifier of this parameter.
Public propertySimplify
Gets or sets the simplify modifier for this parameter.
Public propertySourceCount
Gets the number of sources for this parameter.
Public propertySources
Gets a list of source parameters. Do not modify this list, if you wish to add or remove sources, use dedicated functions like AddSource() and RemoveSource instead.
Public propertyStateTags
Gets all the StateTags that are associated with this parameter. A state tag is a visual feedback icon that represents specific internal settings.
Public propertyType
Gets the Framework Type descriptor for the stored Data.
Public propertyTypeName
Gets a human readable description of the data stored in this parameter.
Public propertyVolatileData
Gets the instance of the volatile data tree stored in this parameter.
Public propertyVolatileDataCount
Gets the total number of volatile data items stored in this parameter.
Public propertyWireDisplay
Gets or sets the wire display style for this parameter. Wire display only affects the wires connected to the parameter input.
Top
See Also