Click or drag to resize

Param_Predicate Class

Inheritance Hierarchy

Namespace:  Grasshopper.Kernel.Parameters
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class Param_Predicate : GH_Param<GH_Predicate>

The Param_Predicate type exposes the following members.

Constructors
  NameDescription
Public methodParam_Predicate
Initializes a new instance of the Param_Predicate class
Top
Properties
  NameDescription
Public propertyComponentGuid (Overrides GH_DocumentObjectComponentGuid.)
Public propertyExposure (Overrides GH_DocumentObjectExposure.)
Public propertyNegate
Public propertyRuntimeMessageLevel
Returns the worst case flag for the current object

If the object contains at least 1 error, the result is Error.

If the object contains at least 1 warning, the result is Warning.

If the object contains at least 1 message, the result is Remark.

If the object contains no errors, no warnings and no messages, the result is Blank.
Public propertyStateTags (Overrides GH_ParamTStateTags.)
Top
Methods
  NameDescription
Public methodAppendAdditionalMenuItems (Overrides GH_ParamTAppendAdditionalMenuItems(ToolStripDropDown).)
Public methodRead (Overrides GH_ParamTRead(GH_IReader).)
Public methodRemoveEffects (Overrides GH_ParamTRemoveEffects.)
Public methodWrite (Overrides GH_ParamTWrite(GH_IWriter).)
Top
Events
  NameDescription
Top
See Also