Click or drag to resize

GH_Hatch Class

Represents an implementation of a Rhino hatch.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooHatch
    Grasshopper.Kernel.TypesGH_GeometricGooHatch
      Grasshopper.Kernel.TypesGH_Hatch

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_Hatch : GH_GeometricGoo<Hatch>, 
	IGH_BakeAwareData, IGH_PreviewData

The GH_Hatch type exposes the following members.

Constructors
  NameDescription
Public methodGH_Hatch
Default constructor, creates an invalid hatch.
Public methodGH_Hatch(GH_Hatch)
Create a duplicate of another GH_Hatch. This constructor also copies reference data.
Public methodGH_Hatch(Guid)
Create a new referenced hatch that references a Rhino hatch with the specified ID.
Public methodGH_Hatch(Hatch)
Create a duplicate of an existing hatch.
Public methodGH_Hatch(Hatch, ModelHatchPattern)
Create a duplicate of an existing hatch.
Top
Properties
  NameDescription
Public propertyBackgroundColor
Public propertyBoundaryVisible
Public propertyBoundingbox (Overrides GH_GeometricGooTBoundingbox.)
Public propertyClippingBox
Public propertyIsGeometryLoaded
Gets the load state of this hatch object. The hatch is considered to be loaded when the local hatch instance is not null.
(Overrides GH_GeometricGooTIsGeometryLoaded.)
Public propertyIsValid
Gets the validity of this hatch. If the hatch is referenced but cannot be loaded, the hatch is not valid.
(Overrides GH_GeometricGooTIsValid.)
Public propertyIsValidWhyNot
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.)
Public propertyPattern
Public propertyReferenceID (Overrides GH_GeometricGooTReferenceID.)
Public propertyTypeDescription (Overrides GH_GooTTypeDescription.)
Public propertyTypeName (Overrides GH_GooTTypeName.)
Public propertyValue (Overrides GH_GeometricGooTValue.)
Top
Methods
  NameDescription
Public methodBakeGeometry
Public methodCastFrom
Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GeometricGooTCastFrom(Object).)
Public methodCastToT(T)
Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GeometricGooTCastToQ(Q).)
Public methodClearCaches
Clears all volatile caches for this instance. The boundingbox is cleared, and if the hatch is referenced, the local instance of the hatch is erased.
(Overrides GH_GeometricGooTClearCaches.)
Public methodDrawViewportMeshes
Public methodDrawViewportWires
Public methodDuplicate (Overrides GH_GeometricGooTDuplicate.)
Public methodDuplicateGeometry
Create a duplicate of this hatch.
(Overrides GH_GeometricGooTDuplicateGeometry.)
Public methodDuplicateHatch
Create a duplicate of this hatch.
Public methodGetBoundingBox (Overrides GH_GeometricGooTGetBoundingBox(Transform).)
Public methodLoadGeometry(RhinoDoc)
If the hatch is referenced and not yet loaded, attempts to load the hatch.
(Overrides GH_GeometricGooTLoadGeometry(RhinoDoc).)
Public methodMorph (Overrides GH_GeometricGooTMorph(SpaceMorph).)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodScriptVariable (Overrides GH_GooTScriptVariable.)
Public methodToString
Format the hatch using default grasshopper formatting logic.
(Overrides GH_GooTToString.)
Public methodTransform (Overrides GH_GeometricGooTTransform(Transform).)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
Fields
See Also