Click or drag to resize

GH_InstanceReference Class

Represents block instance reference. Wraps the functionality of the InstanceReferenceGeometry type.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooInstanceReferenceGeometry
    Grasshopper.Kernel.TypesGH_GeometricGooInstanceReferenceGeometry
      Grasshopper.Kernel.TypesGH_InstanceReference

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_InstanceReference : GH_GeometricGoo<InstanceReferenceGeometry>, 
	IGH_BakeAwareData, IGH_PreviewData, IGH_RenderAwareData

The GH_InstanceReference type exposes the following members.

Constructors
  NameDescription
Public methodGH_InstanceReference
Default constructor, creates an invalid instance reference.
Public methodGH_InstanceReference(GH_InstanceReference)
Create a duplicate of another GH_InstanceReference. This constructor also copies reference data.
Public methodGH_InstanceReference(Guid)
Create a new reference to a Rhino instance reference with the specified ID.
Public methodGH_InstanceReference(InstanceReferenceGeometry)
Create a new reference to a Rhino instance reference with the specified ID.
Public methodGH_InstanceReference(Transform)
Create a duplicate of an existing instance reference.
Public methodGH_InstanceReference(InstanceReferenceGeometry, ModelInstanceDefinition)
Create a new reference to a Rhino instance reference with the specified ID.
Top
Properties
  NameDescription
Public propertyBoundingbox (Overrides GH_GeometricGooTBoundingbox.)
Public propertyClippingBox
Public propertyInstanceDefinition
Public propertyIsGeometryLoaded
Gets the load state of this instance reference object. The instance reference is considered to be loaded when the local instance is not null.
(Overrides GH_GeometricGooTIsGeometryLoaded.)
Public propertyIsReferencedGeometry
Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry.
(Overrides GH_GeometricGooTIsReferencedGeometry.)
Public propertyIsValid
Gets the validity of this instance reference. If the instance reference is referenced but cannot be loaded, the instance reference is not valid.
(Overrides GH_GeometricGooTIsValid.)
Public propertyIsValidWhyNot
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.)
Public propertyModelTransform
Public propertyReferenceID (Overrides GH_GeometricGooTReferenceID.)
Public propertyTypeDescription (Overrides GH_GooTTypeDescription.)
Public propertyTypeName (Overrides GH_GooTTypeName.)
Top
Methods
  NameDescription
Public methodBakeGeometry
Public methodCastFrom
Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GeometricGooTCastFrom(Object).)
Public methodCastToT(T)
Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GeometricGooTCastToQ(Q).)
Public methodClearCaches
Clears all volatile caches for this instance. The boundingbox is cleared, and if the instance reference is referenced, the local instance of the instance reference is erased.
(Overrides GH_GeometricGooTClearCaches.)
Public methodDrawViewportMeshes
Public methodDrawViewportWires
Public methodDuplicate (Overrides GH_GeometricGooTDuplicate.)
Public methodDuplicateGeometry
Create a duplicate of this GH_InstanceReference.
(Overrides GH_GeometricGooTDuplicateGeometry.)
Public methodDuplicateInstanceReference
Create a duplicate of this GH_InstanceReference.
Public methodGetBoundingBox (Overrides GH_GeometricGooTGetBoundingBox(Transform).)
Public methodLoadGeometry(RhinoDoc)
If the instance reference is referenced and not yet loaded, attempts to load the instance reference.
(Overrides GH_GeometricGooTLoadGeometry(RhinoDoc).)
Public methodMorph (Overrides GH_GeometricGooTMorph(SpaceMorph).)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodScriptVariable (Overrides GH_GooTScriptVariable.)
Public methodToString
Format the instance reference using default grasshopper formatting logic.
(Overrides GH_GooTToString.)
Public methodTransform (Overrides GH_GeometricGooTTransform(Transform).)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
Fields
See Also