Click or drag to resize

GH_Light Class

Represents an implementation of a Rhino Light class.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooLight
    Grasshopper.Kernel.TypesGH_GeometricGooLight
      Grasshopper.Kernel.TypesGH_Light

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_Light : GH_GeometricGoo<Light>, 
	IGH_PreviewData, IGH_BakeAwareData

The GH_Light type exposes the following members.

Constructors
  NameDescription
Public methodGH_Light
Default constructor, creates an new light
Public methodGH_Light(GH_Light)
Create a duplicate of another GH_Light. This constructor also copies reference data.
Public methodGH_Light(Guid)
Create a new referenced light that references a Rhino light with the specified ID.
Public methodGH_Light(Light)
Create a duplicate of an existing light.
Top
Properties
  NameDescription
Public propertyBoundingbox (Overrides GH_GeometricGooTBoundingbox.)
Public propertyClippingBox
Public propertyIsGeometryLoaded
Gets the load state of this light object. The light is considered to be loaded when the local light instance is not null.
(Overrides GH_GeometricGooTIsGeometryLoaded.)
Public propertyIsValid
Gets the validity of this light. If the light is referenced but cannot be loaded, then the light is not valid.
(Overrides GH_GeometricGooTIsValid.)
Public propertyIsValidWhyNot
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.)
Public propertyReferenceID (Overrides GH_GeometricGooTReferenceID.)
Public propertyTypeDescription (Overrides GH_GooTTypeDescription.)
Public propertyTypeName (Overrides GH_GooTTypeName.)
Public propertyValue (Overrides GH_GeometricGooTValue.)
Top
Methods
  NameDescription
Public methodBakeGeometry
Public methodCastFrom
Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GeometricGooTCastFrom(Object).)
Public methodCastToT(T)
Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GeometricGooTCastToQ(Q).)
Public methodClearCaches
Clears all volatile caches for this instance. The boundingbox is cleared, and if the light is referenced, the local instance of the light is erased.
(Overrides GH_GeometricGooTClearCaches.)
Public methodDrawViewportMeshes
Public methodDrawViewportWires
Public methodDuplicate (Overrides GH_GeometricGooTDuplicate.)
Public methodDuplicateGeometry
Create a duplicate of this light.
(Overrides GH_GeometricGooTDuplicateGeometry.)
Public methodDuplicateLight
Create a duplicate of this light.
Public methodGetBoundingBox (Overrides GH_GeometricGooTGetBoundingBox(Transform).)
Public methodLoadGeometry(RhinoDoc)
If the light is referenced and not yet loaded, attempts to load the light.
(Overrides GH_GeometricGooTLoadGeometry(RhinoDoc).)
Public methodMorph (Overrides GH_GeometricGooTMorph(SpaceMorph).)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodScriptVariable (Overrides GH_GooTScriptVariable.)
Public methodToString
Format the dimension using default grasshopper formatting logic.
(Overrides GH_GooTToString.)
Public methodTransform (Overrides GH_GeometricGooTTransform(Transform).)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
Fields
See Also