Click or drag to resize

GH_LinearDimension Class

Represents an implementation of a Rhino linear dimension.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooAnnotationBase
    Grasshopper.Kernel.TypesGH_GeometricGooAnnotationBase
      Grasshopper.Kernel.TypesGH_AnnotationBase
        Grasshopper.Kernel.TypesGH_Dimension
          Grasshopper.Kernel.TypesGH_LinearDimension

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_LinearDimension : GH_Dimension

The GH_LinearDimension type exposes the following members.

Constructors
  NameDescription
Public methodGH_LinearDimension
Default constructor, creates an invalid linear dimension.
Public methodGH_LinearDimension(GH_LinearDimension)
Create a duplicate of another GH_LinearDimension. This constructor also copies reference data.
Public methodGH_LinearDimension(Guid)
Create a new referenced linear dimension that references a Rhino dimension with the specified ID.
Public methodGH_LinearDimension(LinearDimension)
Create a duplicate of an existing linear dimension.
Public methodGH_LinearDimension(LinearDimension, ModelAnnotationStyle)
Create a duplicate of an existing linear dimension.
Top
Properties
  NameDescription
Public propertyTypeDescription (Overrides GH_AnnotationBaseTypeDescription.)
Public propertyTypeName (Overrides GH_AnnotationBaseTypeName.)
Public propertyValue
Protected propertyValueType (Overrides GH_DimensionValueType.)
Top
Methods
  NameDescription
Public methodCastFrom
Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GeometricGooTCastFrom(Object).)
Public methodCastToT(T)
Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_DimensionCastToT(T).)
Public methodDuplicateAnnotation
Create a duplicate of this annotation.
(Overrides GH_AnnotationBaseDuplicateAnnotation.)
Public methodDuplicateLinearDimension
Create a duplicate of this linear dimension.
Public methodToString
Format the dimension using default grasshopper formatting logic.
(Overrides GH_AnnotationBaseToString.)
Top
Fields
See Also