Click or drag to resize

GH_TextDot Class

Represents an implementation of a Rhino text dot.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooTextDot
    Grasshopper.Kernel.TypesGH_GeometricGooTextDot
      Grasshopper.Kernel.TypesGH_TextDot

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_TextDot : GH_GeometricGoo<TextDot>, 
	IGH_BakeAwareData, IGH_PreviewData

The GH_TextDot type exposes the following members.

Constructors
  NameDescription
Public methodGH_TextDot
Default constructor, creates an invalid text dot.
Public methodGH_TextDot(GH_TextDot)
Create a duplicate of another GH_TextDot. This constructor also copies reference data.
Public methodGH_TextDot(Guid)
Create a new referenced text dot that references a Rhino text dot with the specified ID.
Public methodGH_TextDot(TextDot)
Create a duplicate of an existing text dot.
Top
Properties
  NameDescription
Public propertyBoundingbox (Overrides GH_GeometricGooTBoundingbox.)
Public propertyClippingBox
Public propertyIsGeometryLoaded
Gets the load state of this text dot object. The text dot is considered to be loaded when the local text dot instance is not null.
(Overrides GH_GeometricGooTIsGeometryLoaded.)
Public propertyIsValid
Gets the validity of this text dot. If the text dot is referenced but cannot be loaded, the text dot is not valid.
(Overrides GH_GeometricGooTIsValid.)
Public propertyIsValidWhyNot
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.)
Public propertyReferenceID (Overrides GH_GeometricGooTReferenceID.)
Public propertyTypeDescription (Overrides GH_GooTTypeDescription.)
Public propertyTypeName (Overrides GH_GooTTypeName.)
Public propertyValue (Overrides GH_GeometricGooTValue.)
Top
Methods
  NameDescription
Public methodBakeGeometry
Public methodCastFrom
Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GeometricGooTCastFrom(Object).)
Public methodCastToT(T)
Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GeometricGooTCastToQ(Q).)
Public methodClearCaches
Clears all volatile caches for this instance. The boundingbox is cleared, and if the text dot is referenced, the local instance of the text dot is erased.
(Overrides GH_GeometricGooTClearCaches.)
Public methodDrawViewportMeshes
Public methodDrawViewportWires
Public methodDuplicate (Overrides GH_GeometricGooTDuplicate.)
Public methodDuplicateGeometry
Create a duplicate of this text dot.
(Overrides GH_GeometricGooTDuplicateGeometry.)
Public methodDuplicateTextDot
Create a duplicate of this text dot.
Public methodGetBoundingBox (Overrides GH_GeometricGooTGetBoundingBox(Transform).)
Public methodLoadGeometry(RhinoDoc)
If the text dot is referenced and not yet loaded, attempts to load the text dot.
(Overrides GH_GeometricGooTLoadGeometry(RhinoDoc).)
Public methodMorph (Overrides GH_GeometricGooTMorph(SpaceMorph).)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodScriptVariable (Overrides GH_GooTScriptVariable.)
Public methodToString
Format the text dot using default grasshopper formatting logic.
(Overrides GH_GooTToString.)
Public methodTransform (Overrides GH_GeometricGooTTransform(Transform).)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
Fields
See Also