Click or drag to resize

IGH_Goo Interface

Base interface for all Data inside Grasshopper. Every parameter must implement a type of Goo.

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public interface IGH_Goo : GH_ISerializable

The IGH_Goo type exposes the following members.

Properties
  NameDescription
Public propertyIsValid
Gets a value indicating whether or not the current value is valid.
Public propertyIsValidWhyNot
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
Public propertyTypeDescription
Gets a description of the type of the implementation.
Public propertyTypeName
Gets the name of the type of the implementation.
Top
Methods
  NameDescription
Public methodCastFrom
Attempt a cast from generic object
Public methodCastToT
Attempt a cast to type T
Public methodDuplicate
Make a complete duplicate of this instance. No shallow copies.
Public methodEmitProxy
Create a new proxy for this instance. Return Null if this class does not support proxies.
Public methodScriptVariable
This function will be called when the local IGH_Goo instance disapears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type.
Public methodToString
Creates a string description of the current instance value
Top
See Also