Click or drag to resize

GH_UndoAction Class

Base class implementation for undo actions.
Inheritance Hierarchy

Namespace:  Grasshopper.Kernel.Undo
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public abstract class GH_UndoAction : IGH_UndoAction

The GH_UndoAction type exposes the following members.

Constructors
  NameDescription
Protected methodGH_UndoAction
Initializes a new instance of the GH_UndoAction class
Top
Properties
  NameDescription
Public propertyExpiresDisplay
Override this property if you want the Rhino viewport display to refresh upon undo completion.
Public propertyExpiresSolution
Override this property if you want the Grasshopper solution to refresh upon undo completion.
Public propertyState
Top
Methods
See Also