Click or drag to resize

ModelAnnotationStyleAttributes Class

Inheritance Hierarchy

Namespace:  Grasshopper.Rhinoceros.Annotations
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class Attributes : ModelComponentContentAttributes, IEquatable<ModelAnnotationStyleAttributes>

The ModelAnnotationStyleAttributes type exposes the following members.

Constructors
  NameDescription
Public methodModelAnnotationStyleAttributes
Initializes a new instance of the ModelAnnotationStyleAttributes class
Top
Properties
Methods
  NameDescription
Protected methodEquals(Object, IEqualityComparer) (Overrides ModelComponentContentAttributesEquals(Object, IEqualityComparer).)
Protected methodGetHashCode(IEqualityComparer) (Overrides ModelComponentContentAttributesGetHashCode(IEqualityComparer).)
Protected methodReadData (Overrides ModelComponentContentAttributesReadData(GH_IReader).)
Public methodToDetails (Overrides ModelComponentContentAttributesToDetails.)
Public methodToModelData (Overrides ModelDataAttributesToModelData.)
Protected methodWriteData (Overrides ModelComponentContentAttributesWriteData(GH_IWriter).)
Top
Operators
See Also