Click or drag to resize

ModelComponentContentAttributes Class

Inheritance Hierarchy

Namespace:  Grasshopper.Rhinoceros
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public abstract class Attributes : ModelContentAttributes, 
	IEquatable<ModelComponentContentAttributes>

The ModelComponentContentAttributes type exposes the following members.

Constructors
  NameDescription
Protected methodModelComponentContentAttributes
Initializes a new instance of the ModelComponentContentAttributes class
Top
Properties
Methods
  NameDescription
Protected methodEquals(Object, IEqualityComparer) (Overrides ModelContentAttributesEquals(Object, IEqualityComparer).)
Protected methodGetHashCode(IEqualityComparer) (Overrides ModelContentAttributesGetHashCode(IEqualityComparer).)
Protected methodReadData (Overrides ModelContentAttributesReadData(GH_IReader).)
Public methodToDetails (Overrides ModelDataAttributesToDetails.)
Protected methodWriteData (Overrides ModelContentAttributesWriteData(GH_IWriter).)
Top
See Also
Inheritance Hierarchy
SystemObject
  Grasshopper.RhinocerosModelDataAttributes
    Grasshopper.RhinocerosModelContentAttributes
      Grasshopper.RhinocerosModelComponentContentAttributes
        Grasshopper.Rhinoceros.AnnotationsModelAnnotationStyleAttributes
        Grasshopper.Rhinoceros.DraftingModelHatchPatternAttributes
        Grasshopper.Rhinoceros.DraftingModelLinetypeAttributes
        Grasshopper.Rhinoceros.ModelModelInstanceDefinitionAttributes
        Grasshopper.Rhinoceros.ModelModelLayerAttributes
        Grasshopper.Rhinoceros.ModelModelObjectAttributes