Click or drag to resize

Param_AnnotationLeaderSettings Class

Inheritance Hierarchy
SystemObject
  Grasshopper.KernelGH_InstanceDescription
    Grasshopper.KernelGH_DocumentObject
      Grasshopper.KernelGH_ActiveObject
        Grasshopper.KernelGH_ParamAnnotationLeaderSettings
          Grasshopper.Rhinoceros.ParamsModelDataParamAnnotationLeaderSettings
            Grasshopper.Rhinoceros.Annotations.ParamsParam_AnnotationLeaderSettings

Namespace:  Grasshopper.Rhinoceros.Annotations.Params
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class Param_AnnotationLeaderSettings : ModelDataParam<AnnotationLeaderSettings>

The Param_AnnotationLeaderSettings type exposes the following members.

Constructors
  NameDescription
Public methodParam_AnnotationLeaderSettings
Initializes a new instance of the Param_AnnotationLeaderSettings class
Top
Properties
  NameDescription
Public propertyComponentGuid (Overrides GH_DocumentObjectComponentGuid.)
Public propertyExposure (Overrides GH_DocumentObjectExposure.)
Protected propertyIcon (Overrides ModelDataParamTIcon.)
Public propertyRuntimeMessageLevel
Returns the worst case flag for the current object

If the object contains at least 1 error, the result is Error.

If the object contains at least 1 warning, the result is Warning.

If the object contains at least 1 message, the result is Remark.

If the object contains no errors, no warnings and no messages, the result is Blank.
Top
Methods
  NameDescription
Protected methodPreferredCast (Overrides GH_ParamTPreferredCast(Object).)
Top
Events
  NameDescription
Top
Fields
See Also