Click or drag to resize

ModelHatchPattern Class

Represents a Rhino model hatch pattern. Wraps the functionality of the HatchPattern type.
Inheritance Hierarchy

Namespace:  Grasshopper.Rhinoceros.Drafting
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class ModelHatchPattern : ModelComponentContent, 
	IGH_BakeAwareData

The ModelHatchPattern type exposes the following members.

Constructors
  NameDescription
Public methodModelHatchPattern
Initializes a new instance of the ModelHatchPattern class
Public methodModelHatchPattern(ModelHatchPatternAttributes)
Initializes a new instance of the ModelHatchPattern class
Public methodModelHatchPattern(Guid)
Initializes a new instance of the ModelHatchPattern class
Public methodModelHatchPattern(HatchPattern)
Initializes a new instance of the ModelHatchPattern class
Top
Properties
  NameDescription
Public propertyFillType
Public propertyLines
Public propertyStatic memberUnset
Top
Methods
Operators
See Also