Click or drag to resize

ModelContent Class

Represents a Rhino model element.
Inheritance Hierarchy
SystemObject
  Grasshopper.RhinocerosModelData
    Grasshopper.RhinocerosModelContent
      More...

Namespace:  Grasshopper.Rhinoceros
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public abstract class ModelContent : ModelData, 
	IGH_ModelContentData, IEquatable<ModelContent>

The ModelContent type exposes the following members.

Constructors
  NameDescription
Protected methodModelContent
Initializes a new instance of the ModelContent class
Top
Properties
Methods
  NameDescription
Public methodStatic memberCast(Object)
Protected methodStatic memberCastA, T(Object)
Public methodCastToT(T) (Overrides ModelDataCastToT(T).)
Public methodEquals(ModelContent)
Public methodEquals(Object) (Overrides ModelDataEquals(Object).)
Public methodStatic memberFromId
Public methodGetHashCode (Overrides ModelDataGetHashCode.)
Protected methodInternaliseData
Protected methodLoadReferencedData
Protected methodRead (Overrides ModelDataRead(GH_IReader).)
Protected methodRuntimeId
Public methodToAttributes
Public methodTooltipString (Overrides ModelDataTooltipString.)
Public methodToString (Overrides ModelDataToString.)
Protected methodUnloadReferencedData
Protected methodWrite (Overrides ModelDataWrite(GH_IWriter).)
Top
See Also
Inheritance Hierarchy