Click or drag to resize

ModelLinetypeAttributes Class

Inheritance Hierarchy

Namespace:  Grasshopper.Rhinoceros.Drafting
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class Attributes : ModelComponentContentAttributes, IEquatable<ModelLinetypeAttributes>

The ModelLinetypeAttributes type exposes the following members.

Constructors
  NameDescription
Public methodModelLinetypeAttributes
Initializes a new instance of the ModelLinetypeAttributes class
Top
Properties
Methods
  NameDescription
Protected methodEquals(Object, IEqualityComparer) (Overrides ModelComponentContentAttributesEquals(Object, IEqualityComparer).)
Protected methodGetHashCode(IEqualityComparer) (Overrides ModelComponentContentAttributesGetHashCode(IEqualityComparer).)
Protected methodReadData (Overrides ModelComponentContentAttributesReadData(GH_IReader).)
Public methodToDetails (Overrides ModelComponentContentAttributesToDetails.)
Public methodToModelData (Overrides ModelDataAttributesToModelData.)
Protected methodWriteData (Overrides ModelComponentContentAttributesWriteData(GH_IWriter).)
Top
Operators
See Also