Click or drag to resize

ModelObject Class

Represents a Rhino model object. Wraps the functionality of the RhinoObject type.
Inheritance Hierarchy

Namespace:  Grasshopper.Rhinoceros.Model
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class ModelObject : ModelComponentContent, 
	IGH_BakeAwareData, IGH_PreviewData, IGH_PreviewMeshData, IGH_RenderAwareData

The ModelObject type exposes the following members.

Constructors
  NameDescription
Public methodModelObject
Initializes a new instance of the ModelObject class
Public methodModelObject(ModelObjectAttributes)
Initializes a new instance of the ModelObject class
Public methodModelObject(Guid)
Initializes a new instance of the ModelObject class
Public methodModelObject(RhinoObject)
Initializes a new instance of the ModelObject class
Public methodModelObject(RhinoDoc, ObjectAttributes)
Initializes a new instance of the ModelObject class
Public methodModelObject(RhinoDoc, ObjectAttributes, GeometryBase)
Initializes a new instance of the ModelObject class
Top
Properties
Methods
  NameDescription
Public methodStatic memberCast
Public methodCastToT(T) (Overrides ModelContentCastToT(T).)
Protected methodClearCaches
Public methodDestroyPreviewMeshes
Public methodGetBoundingBox
Public methodToAttributes
Public methodTooltipString (Overrides ModelContentTooltipString.)
Public methodToString (Overrides ModelContentToString.)
Top
Operators
See Also