Click or drag to resize

ModelObjectAttributes Class

Inheritance Hierarchy

Namespace:  Grasshopper.Rhinoceros.Model
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class Attributes : ModelComponentContentAttributes, IEquatable<ModelObjectAttributes>

The ModelObjectAttributes type exposes the following members.

Constructors
  NameDescription
Public methodModelObjectAttributes
Initializes a new instance of the ModelObjectAttributes class
Top
Properties
Methods
  NameDescription
Protected methodEquals(Object, IEqualityComparer) (Overrides ModelComponentContentAttributesEquals(Object, IEqualityComparer).)
Protected methodGetHashCode(IEqualityComparer) (Overrides ModelComponentContentAttributesGetHashCode(IEqualityComparer).)
Protected methodIsValidContentName (Overrides ModelContentAttributesIsValidContentName(ModelContentName).)
Protected methodReadData (Overrides ModelComponentContentAttributesReadData(GH_IReader).)
Public methodToDetails (Overrides ModelComponentContentAttributesToDetails.)
Public methodToModelData (Overrides ModelDataAttributesToModelData.)
Protected methodWriteData (Overrides ModelComponentContentAttributesWriteData(GH_IWriter).)
Top
See Also