OrderListBox

Displays a sizeable Windows dialog box with an orderable list box. Items can be moved by dragging, or by using the move buttons.

Syntax

Rhino.OrderListBox (arrItems [, strMessage [, strTitle [, blnReturnStrings [, arrPos]]]])

Parameters

arrItems

Required.  Array.  An array of strings.

strMessage

Optional.  String.  A prompt or message.

strTitle

Optional.  String.  A dialog box title.

blnReturnStrings

Optional.  Boolean.  If not specified or True, then the ordered list of strings. If False, then the sort order is returned.

arrPos

Optional.  Array.  A 2-D screen point that identifies the upper left corner of the dialog's initial position.

Returns

Array

If blnReturnStrings is True, then the ordered strings if successful.

Array

If blnReturnStrings is False, then a zero-based array of sort indices if successful.

Null

If not successful, or on error.

Example

Dim arrItems, arrResults, strItem

arrItems = Array("Item0", "Item1", "Item2", "Item3")

arrResults = Rhino.OrderListbox(arrItems, "Drag items to move", "Order Items")

If IsArray(arrResults) Then

  For Each strItem in arrResults

    Rhino.Print strItem

  Next

End If

orderlistbox.jpg

Also See

CheckListBox

ComboListBox

EditListBox

ListBox

MultiListBox

PropertyListBox