Rhino C++ API  8.5
Public Member Functions | List of all members
CRhRdkInstanceIdArray Class Referencefinal

#include <RhRdkContent.h>

Inheritance diagram for CRhRdkInstanceIdArray:
ON_SimpleArray< UUID >

Public Member Functions

bool operator== (const CRhRdkInstanceIdArray &a) const
 
- Public Member Functions inherited from ON_SimpleArray< UUID >
 ON_SimpleArray () ON_NOEXCEPT
 construction //////////////////////////////////////////////////////// More...
 
 ON_SimpleArray (const ON_SimpleArray< UUID > &)
 Copy constructor. More...
 
 ON_SimpleArray (size_t)
 size_t parameter = initial capacity More...
 
virtual ~ON_SimpleArray ()
 
void Append (const UUID &)
 
void Append (int, const UUID *)
 Append copy of an array T[count]. More...
 
UUID & AppendNew ()
 array operations //////////////////////////////////////////////////// More...
 
UUID * Array ()
 The Array() function return the. More...
 
const UUID * Array () const
 m_a pointer value. More...
 
UUID * At (int)
 At(index) returns nullptr if index < 0 or index >= count. More...
 
const UUID * At (int) const
 
UUID * At (ON__INT64)
 
const UUID * At (ON__INT64) const
 
UUID * At (ON__UINT64)
 
const UUID * At (ON__UINT64) const
 
UUID * At (unsigned int)
 
const UUID * At (unsigned int) const
 
int BinarySearch (const UUID *, int(*)(const UUID *, const UUID *)) const
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
int BinarySearch (const UUID *, int(*)(const UUID *, const UUID *), int) const
 
const UUID * BinarySearchPtr (const UUID *, int(*)(const UUID *, const UUID *)) const
 
const UUID * BinarySearchPtr (const UUID *, int(*)(const UUID *, const UUID *), int) const
 
int Capacity () const
 capacity of array More...
 
int Count () const
 query /////////////////////////////////////////////////////////////// More...
 
ON__UINT32 DataCRC (ON__UINT32 current_remainder) const
 
void Destroy ()
 onfree any memory and set count and capacity to zero More...
 
void EmergencyDestroy (void)
 emergency bailout /////////////////////////////////////////////////// More...
 
void Empty ()
 Sets count to 0, leaves capacity untouched. More...
 
UUID * First ()
 
const UUID * First () const
 returns nullptr if count = 0 More...
 
bool HeapSort (int(*)(const UUID *, const UUID *))
 
void Insert (int, const UUID &)
 
int InsertInSortedList (const UUID &, int(*)(const UUID *, const UUID *))
 
int InsertInSortedList (const UUID &, int(*)(const UUID *, const UUID *), int)
 
UUID * KeepArray ()
 
UUID * Last ()
 
const UUID * Last () const
 returns nullptr if count = 0 More...
 
void MemSet (unsigned char)
 
int NewCapacity () const
 
 operator const UUID * () const
 
 operator UUID * ()
 The cast operators return a pointer. More...
 
ON_SimpleArray< UUID > & operator= (const ON_SimpleArray< UUID > &)
 
UUID & operator[] (int)
 
const UUID & operator[] (int) const
 
UUID & operator[] (ON__INT64)
 
const UUID & operator[] (ON__INT64) const
 
UUID & operator[] (ON__UINT64)
 
const UUID & operator[] (ON__UINT64) const
 
UUID & operator[] (unsigned int)
 
const UUID & operator[] (unsigned int) const
 
bool Permute (const int *)
 
void Prepend (int, const UUID *)
 Prepend copy of an array T[count]. More...
 
bool QuickSort (int(*)(const UUID *, const UUID *))
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
bool QuickSortAndRemoveDuplicates (int(*)(const UUID *, const UUID *))
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
virtual UUID * Realloc (UUID *, int)
 low level memory management ////////////////////////////////////////// More...
 
void Remove ()
 
virtual void Remove (int)
 
void RemoveIf (bool predicate(const UUID &key))
 
void RemoveValue (const UUID &)
 
UUID * Reserve (size_t)
 memory management //////////////////////////////////////////////////// More...
 
void Reverse ()
 reverse order More...
 
int Search (const UUID &) const
 
int Search (const UUID *, int(*)(const UUID *, const UUID *)) const
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
void SetArray (UUID *)
 
void SetArray (UUID *, int, int)
 
UUID * SetCapacity (size_t)
 
void SetCount (int)
 low level memory management ////////////////////////////////////////// More...
 
void SetRange (int from, int count, UUID)
 
void Shrink ()
 remove unused capacity More...
 
unsigned int SizeOfArray () const
 amount of memory in the m_a[] array More...
 
unsigned int SizeOfElement () const
 amount of memory in an m_a[] array element More...
 
bool Sort (ON::sort_algorithm sort_algorithm, int *, int(*)(const UUID *, const UUID *)) const
 
bool Sort (ON::sort_algorithm sort_algorithm, int *, int(*)(const UUID *, const UUID *, void *), void *) const
 
void Swap (int, int)
 swap elements i and j More...
 
unsigned int UnsignedCount () const
 
void Zero ()
 

Additional Inherited Members

- Protected Member Functions inherited from ON_SimpleArray< UUID >
void Move (int, int, int)
 implementation ////////////////////////////////////////////////////// More...
 
- Protected Attributes inherited from ON_SimpleArray< UUID >
UUID * m_a
 pointer to array memory More...
 
int m_capacity
 actual length of m_a[] More...
 
int m_count
 0 <= m_count <= m_capacity More...
 

Detailed Description

A collection of content instance ids.

Member Function Documentation

◆ operator==()

bool CRhRdkInstanceIdArray::operator== ( const CRhRdkInstanceIdArray a) const