Rhino C++ API
8.14
|
#include <RhRdkRenderWindowEventSink.h>
Public Member Functions | |
virtual class CRhinoUiDockBarTab * | NewTabEx (CRhRdkControllerPtr con, HWND parent) const =0 |
![]() | |
virtual UUID | InterfaceId (void) const final override |
virtual class CRhinoUiDockBarTab * | NewTab (IRhRdkRenderWindow &) const =0 |
virtual UUID | RenderEngineId (void) const =0 |
virtual UUID | TabId (void) const =0 |
![]() | |
CRhRdkExtension () | |
virtual | ~CRhRdkExtension () |
virtual UUID | PlugInId (void) const =0 |
bool | Unregister (void) |
![]() | |
CRhRdkObject () | |
virtual | ~CRhRdkObject () |
virtual void * | EVF (const wchar_t *wszFunc, void *pvData) |
void | operator delete (void *buf) |
void | operator delete[] (void *buf) |
void * | operator new (size_t size) |
void * | operator new[] (size_t size) |
Additional Inherited Members | |
![]() | |
static void | CheckMemory (void) |
static void | PopulateDebuggingInfo (void) |
This was an extension for use on the Mac although I'm not sure it was ever used there. It's now deprecated (from Rhino 8) due to it not working in the cross-platform (Eto) UI.
|
pure virtual |