Rhino C++ API
8.13
|
#include <RhRdkRenderWindowEventSink.h>
Public Member Functions | |
virtual UUID | InterfaceId (void) const final override |
virtual class CRhinoUiDockBarTab * | NewTab (IRhRdkRenderWindow &) const =0 |
virtual UUID | RenderEngineId (void) const =0 |
virtual UUID | TabId (void) const =0 |
Public Member Functions inherited from CRhRdkExtension | |
CRhRdkExtension () | |
virtual | ~CRhRdkExtension () |
virtual UUID | PlugInId (void) const =0 |
bool | Unregister (void) |
Public Member Functions inherited from CRhRdkObject | |
CRhRdkObject () | |
virtual | ~CRhRdkObject () |
virtual void * | EVF (const wchar_t *wszFunc, void *pvData) |
void | operator delete (void *buf) |
void | operator delete[] (void *buf) |
void * | operator new (size_t size) |
void * | operator new[] (size_t size) |
Additional Inherited Members | |
Static Public Member Functions inherited from CRhRdkObject | |
static void | CheckMemory (void) |
static void | PopulateDebuggingInfo (void) |
RDK provides 3 tabs on the Render Window's main side pane for 'Early', 'Tone Mapping' and 'Late' Post-Effects. This class is an RDK extension which is supposed to allow users to add their own tabs to this pane. This worked in the MFC UI but it's now deprecated (from Rhino 8) due to it not working in the cross-platform (Eto) UI.
|
finaloverridevirtual |
Returns the unique interface id of this extension.
Implements CRhRdkExtension.
|
pure virtual |
|
pure virtual |
|
pure virtual |