Rhino C++ API
8.17
|
#include <RhinoSdkColorButton.h>
Public Member Functions | |
CRhinoColorButton () | |
virtual | ~CRhinoColorButton () |
bool | OnButtonClicked () override |
![]() | |
CRhinoUiColorButton () | |
virtual | ~CRhinoUiColorButton () |
COLORREF | Color () |
HPALETTE | ColorPalette () |
void | Initialize (COLORREF color=::GetSysColor(COLOR_BTNFACE), HPALETTE hPalette=0, bool bSuppressTextWhenEnabled=true) |
virtual bool | OnColorButtonClicked () |
CRhinoUiButton override. More... | |
void | SetColor (COLORREF cr) |
void | SetColor (const unsigned char r, const unsigned char g, const unsigned char b) |
void | SetColorPalette (HPALETTE hp) |
![]() | |
CRhinoUiButton () | |
virtual | ~CRhinoUiButton () |
COLORREF | ButtonColor () const |
bool | ButtonIsHot () const |
void | DrawButtonBitmap (CDC &dc, CRect r) |
bool | DrawButtonFrame () const |
void | DrawButtonText (CDC &dc, CRect rText) |
virtual void | DrawItem (LPDRAWITEMSTRUCT) |
CImageList * | GetImageList (image_list il) const |
CSize | GetImageListImageSize (image_list il) const |
int | GetImageListIndex (image_list il) const |
const wchar_t * | GetToolTipText () const |
bool | IsBitmapButton () const |
bool | IsColorButton () const |
bool | IsMenuButton () const |
afx_msg int | OnCreate (LPCREATESTRUCT lpCreateStruct) |
void | OnCustomMouseButtonDown () |
afx_msg void | OnLButtonDown (UINT nFlags, CPoint point) |
Event handlers. More... | |
afx_msg void | OnLButtonUp (UINT nFlags, CPoint point) |
afx_msg void | OnMButtonDown (UINT nFlags, CPoint point) |
afx_msg void | OnMButtonUp (UINT nFlags, CPoint point) |
afx_msg void | OnMouseMove (UINT nFlags, CPoint point) |
afx_msg void | OnPaint () |
afx_msg void | OnRButtonDown (UINT nFlags, CPoint point) |
afx_msg void | OnRButtonUp (UINT nFlags, CPoint point) |
afx_msg void | OnTimer (UINT_PTR nIDEvent) |
void | SetButtonColor (COLORREF cr=ON_UNSET_COLOR) |
CImageList * | SetImageList (CImageList *pImageList, image_list il) |
int | SetImageListIndex (int iIndex, image_list il) |
bool | SetIsMenuButton (bool b) |
bool | SetSuppressButtonFrameWhenNotHot (bool b) |
void | SetSuppressTextWhenEnabled (bool b) |
void | SetToolTipText (const wchar_t *lpsTip) |
bool | SuppressButtonFrameWhenNotHot () const |
bool | SuppressTextWhenEnabled () const |
Copyright (c) 1993-2017 Robert McNeel & Associates. All rights reserved. Rhinoceros is a registered trademark of Robert McNeel & Associates.
THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF MERCHANTABILITY ARE HEREBY DISCLAIMED.
For complete Rhino SDK copyright information see http://www.rhino3d.com/developer.
CRhinoColorButton::CRhinoColorButton | ( | ) |
|
virtual |
|
overridevirtual |
Reimplemented from CRhinoUiColorButton.